Apache avec 2 nom de domaines

Venez poser vos questions, répondre aux interrogations des autres ou simplement vous renseigner.
Jeune Pingouin
Message(s) : 22
Inscription : 23 Jan 2016 19:44

Apache avec 2 nom de domaines

Message par sechanbask » 22 Fév 2018 11:28

Bonjour,

J'ai besoin d'héberger plusieurs site WEB avec des noms de domaine différents par exemple kb.atenbet.fr et kb.ategie.fr bkl.atenbet.fr et bkl.ategie.fr. Le serveur web en atenbet.fr fonctionne sans soucis mais j'essaie de mettre en plan les ategie.fr

Pour des raisons d'accès depuis le réseaux local, j'ai sur ce serveur bind9 qui me sert de serveur DNS.

Depuis l'un de mes pc client sous W7 si je fais :

Code : Tout sélectionner
nslookup kb.ategie.fr

201.30.168.192.in-addr.arpa
   primary name server = localhost
   responsible mail addr = root.localhost
   serial  = 13
   refresh = 604800 (7 days)
   retry   = 86400 (1 day)
   expire  = 2419200 (28 days)
   default TTL = 604800 (7 days)
Serveur :   UnKnown
Address:  192.168.30.201

Nom :    kb.ategie.fr
Address:  192.168.30.201


ça pointe bien vers le serveur en question.


Mais lorsque je vais sur kb.ategie.fr depuis un PC client, mes navigateurs m'ouvrent la page https://bkl.atenbet.fr/



Donc je pense que j'ai un problème au niveau d'apache, ou mais lequel ?



voici mon vhost kb.ategie.fr

Code : Tout sélectionner
<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        ServerName kb.ategie.fr
        DocumentRoot /srv/kanboard

        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>

        <Directory /srv/kanboard//>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride all
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/kb.ategie.fr_error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/kb.ategie.fr.log combined
</VirtualHost>





voici mon vhost bkl.atenbet.fr


Code : Tout sélectionner
<IfModule mod_ssl.c>
<VirtualHost _default_:443>
        ServerAdmin webmaster@localhost
        ServerName bkl.atenbet.fr
        DocumentRoot /srv/baikal-flat


        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /srv/baikal-flat/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/bkl_error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/ssl_access.log combined

        #   SSL Engine Switch:
        #   Enable/Disable SSL for this virtual host.
        SSLEngine on

        #   A self-signed (snakeoil) certificate can be created by installing
        #   the ssl-cert package. See
        #   /usr/share/doc/apache2.2-common/README.Debian.gz for more info.
        #   If both key and certificate are stored in the same file, only the
        #   SSLCertificateFile directive is needed.
        SSLCertificateFile    /etc/ssl/certs/wildcard.atenbet.fr.crt
        SSLCertificateKeyFile /etc/ssl/private/wildcard.atenbet.fr.key

   
        <FilesMatch "\.(cgi|shtml|phtml|php)$">
                SSLOptions +StdEnvVars
        </FilesMatch>
        <Directory /usr/lib/cgi-bin>
                SSLOptions +StdEnvVars
        </Directory>
        BrowserMatch "MSIE [2-6]" \
                nokeepalive ssl-unclean-shutdown \
                downgrade-1.0 force-response-1.0
                BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown

</VirtualHost>
</IfModule>





mon

Code : Tout sélectionner
# /etc/hosts

127.0.0.1 localhost.localdomain localhost
192.168.30.201 ategie.fr
# Auto-generated hostname. Please do not remove this comment.
192.168.30.201 srv.atenbet.fr  srv cms.atenbet.fr cms
::1 localhost.localdomain localhost
# --- BEGIN PVE ---
192.168.30.201 srv.atenbet.fr srv
# --- END PVE ---




mon

Code : Tout sélectionner
# hostname -A
ategie.fr


Code : Tout sélectionner
# hostname
srv




mon

Code : Tout sélectionner
/etc/resolv.conf

# --- BEGIN PVE ---
search atenbet.local
nameserver 8.8.8.8
# --- END PVE ---



J'aimerais bien comprendre ce que j'ai mal paramétré. Les différence entre hostname et hostname -A me paraissent bizarre et mon resolv.conf aussi. Comme remettre ça correctement et tout faire fonctionner ?

Grand Pingouin
Avatar de l’utilisateur
Message(s) : 109
Inscription : 23 Oct 2015 11:18

Re: Apache avec 2 nom de domaines

Message par disciplus » 22 Fév 2018 11:46

Il est possible que greg ne réponde avant que je puisse finir ce message. :-)
Mais je pense que tu as un problème de DNS lorsque tes clients tentent de se connecter.

Ne connaissant pas ton niveau, je vais commencer avec la base sans vouloir être désagreable :
- Vide les caches DNS
- vide les caches de tes navigateurs
- les config de tes virtualhost match telle correctement? reload de l'apache

Une fois que cela est fait que
- retest avec ton win7
- marque nous les messages de log var/log/httpd
-et marque le nslookup pour les 3 zone :
kb.atenbet.fr et kb.ategie.fr bkl.atenbet.fr et bkl.ategie.fr

Solution 2 pour savoir si ça vient de ton serveur DNS marque directement les entrées dans le fichier host du windows 7.

Je me trompe peux être pour le coup du fichier host en local.

Grand Pingouin
Avatar de l’utilisateur
Message(s) : 109
Inscription : 23 Oct 2015 11:18

Re: Apache avec 2 nom de domaines

Message par disciplus » 22 Fév 2018 12:10

proposition 3 :
ton <VirtualHost _default_:443> ne devrait il pas etre <VirtualHost *:443>?

Autre piste:
-ton fichier host est étrange, et je ne pense pas qu'il fonctionne correctement. il ne faudrait qu'une seul ligne par IP pour les nom, sinon, il me semble que la dernière gagne.

Jeune Pingouin
Message(s) : 22
Inscription : 23 Jan 2016 19:44

Re: Apache avec 2 nom de domaines

Message par sechanbask » 22 Fév 2018 12:25

tous mes p***** de problème venez des caches !!

Code : Tout sélectionner
ipconfig /flushdns


et vidage du cache de Firefox !!

j'ai plus qu'à mettre en place tous mes sites...

Grand Pingouin
Avatar de l’utilisateur
Message(s) : 109
Inscription : 23 Oct 2015 11:18

Re: Apache avec 2 nom de domaines

Message par disciplus » 22 Fév 2018 12:28

impec, bonne mise en prod alors

Retour vers Entraide Linux