Soucis Debian sur EeePC

Venez poser vos questions, répondre aux interrogations des autres ou simplement vous renseigner.
Oeuf
Message(s) : 2
Inscription : 08 Jan 2016 16:10

Soucis Debian sur EeePC

Message par Maxime » 08 Jan 2016 16:24

Bonjour à tous,

Après l'installation de Debian Xfce hier sur mon EeePC, il y a deux ou trois trucs qui ne fonctionnent pas bien. D'abord, l'ordi démarre mal, voire pas du tout parfois : un message d'erreur apparaît au beau milieu de lignes de codes, auxquelles je ne comprends rien bien sur. Alors, parfois il va démarrer, sinon je suis obligé de l'éteindre puis de le rallumer jusqu'à ce que ça fonctionne. Et deuxième petit truc embêtant, je n'ai pas de son. J'ai beau farfouiller un peu partout dans la machine et les paramètres, je ne trouve rien pour régler le son, hormis les raccourcis de mon clavier (mais cela n'a aucun effet).

Merci d'avance pour votre aide !

Grand Pingouin
Message(s) : 101
Inscription : 12 Oct 2015 11:25

Re: Soucis Debian sur EeePC

Message par agaric » 08 Jan 2016 23:36

Bonjour,

Quelle version de Debian et quelles sont les caractéristiques du eePC ?
As-tu fais une analyse SMART du disque dur?
As-tu fais un memtest?

Grand Pingouin
Avatar de l’utilisateur
Message(s) : 100
Inscription : 01 Oct 2015 21:09
Localisation : Lorient

Re: Soucis Debian sur EeePC

Message par ronan311 » 09 Jan 2016 14:18

Salut Maxime !
un message d'erreur apparaît au beau milieu de lignes de codes

Pourrais-tu nous dire ce que raconte ce message d'erreur stp ? S'il est trop long tu peux prendre une photo, l'uploader ici :https://framapic.org/ et nous coller le lien ?

Et deuxième petit truc embêtant, je n'ai pas de son


Ouvre un terminal, tape cette commande :
Code : Tout sélectionner
alsamixer

Si cette commande te renvoie sur une interface à base de fader(s) aux couleurs chatoyantes, vérifie leur niveau (règle les avec les touches directionnelles du clavier).
Vérifie également que les faders ne sont pas mutés, regarde en dessous de chaque fader de lecture (et non de capture) qu'il y a bien une valeur numérique correspondant au niveau audio et non un double "M" qui signifie que ledit fader est muté. Pour le démuter, faut juste appuyer sur la touche "m" de ton clavier.

Raconte nous comment tout ça s'est passé une fois que c'est fait :-)

Très vieux Pingouin
Message(s) : 265
Inscription : 23 Juil 2015 13:56

Re: Soucis Debian sur EeePC

Message par frem » 10 Jan 2016 20:08

QQes infos de contexte :
Maxime est venu ce jeudi et je lui ai installé son poste (voir wiki pour les infos sur ce qui a été installé), mais ça n’est pas un spécialiste Linux, plutôt en apprentissage.

agaric a écrit :Quelle version de Debian et quelles sont les caractéristiques du eePC ?

Nous n’avons pas trouvé que très peu d’infos sur la coque de l’ordinateur. Je viens d’ajouter les infos dont je me souviens sur le wiki (dd 320 Gio et 1 Gio RAM, châssis Seashell, à priori parmi les derniers modèles).
Maxime, peut-être pourrais-tu récupérer des infos (n° de série,…) sur la coque et aller sur le site d’Asus avec ces infos pour récupérer le modèle exact de ton poste et qqes autres infos.

ronan311 a écrit :Pourrais-tu nous dire ce que raconte ce message d'erreur stp ? S'il est trop long tu peux prendre une photo, l'uploader et nous coller le lien ?

Très bonne idée, peut-être même une vidéo du démarrage pour qu’on puisse voir l’enchaînement des commandes.
Si tu ne sais pas où déposer les photos ou vidéos, dis-le nous, nous t’ouvrirons un espace pour les déposer.

Oeuf
Message(s) : 2
Inscription : 08 Jan 2016 16:10

Re: Soucis Debian sur EeePC

Message par Maxime » 11 Jan 2016 16:06

Bien le bonjour,

ronan311 a écrit :Ouvre un terminal, tape cette commande :

Code :
alsamixer


Si cette commande te renvoie sur une interface à base de fader(s) aux couleurs chatoyantes, vérifie leur niveau (règle les avec les touches directionnelles du clavier).
Vérifie également que les faders ne sont pas mutés, regarde en dessous de chaque fader de lecture (et non de capture) qu'il y a bien une valeur numérique correspondant au niveau audio et non un double "M" qui signifie que ledit fader est muté. Pour le démuter, faut juste appuyer sur la touche "m" de ton clavier.


J'ai suivi ton conseil. Je n'ai trouvé qu'une jauge à régler (ce qui doit être un fader je pense), et qui était en effet mutée. Je l'ai démutée, et j'ai maintenant du son uniquement si je branche un casque ou autre sur la prise jack de l'ordi, mais pas sans accessoire...

Je n'ai pas trouvé d'infos supplémentaires sur la coque de l'ordi.

Je vous envoie quelques photos de ce qui peut se passer quand je démarre. Après avoir "unlocké" le disque dur, voici ce qui se passe :
https://framapic.org/dOVF9P4In9ei/wWTLvN9atP7g?dl. Et là, je ne peux plus rien faire.
Ou alors, ça peut également se passer comme ça, dans l'ordre chronologique :
https://framapic.org/4rfuH5c5ySSZ/zlAHOaoov53a?dl ; https://framapic.org/5bFzqdB34gfO/cARbyjpr8Z9r?dl ; https://framapic.org/fsri5y5B9CR0/HdzsZHnaawo1?dl ; https://framapic.org/Ywni9FeiiqT8/eInAnJljMb5u?dl ; https://framapic.org/jdweojfqb60h/GxUZLckpwsLX?dl ; https://framapic.org/pQWW8xRhbGdC/2NCOvRSZ0Gpj?dl.

J'ai emmené la bête chez un ami informaticien. Elle ne démarre quasiment plus (miracle, ça a fonctionné ce matin et j'ai pu récupérer ce que j'avais à récupérer sur le disque dur). Il est fort possible que ce soit un problème avec la carte son. Je vous tiendrai au courant de son état de santé si vous le souhaitez.

J'ai essayé d'être le plus clair possible. Merci pour tout.

Grand Pingouin
Message(s) : 101
Inscription : 12 Oct 2015 11:25

Re: Soucis Debian sur EeePC

Message par agaric » 12 Jan 2016 00:32

Pour avoir une meilleur idée de ce que donne la commande alsamixer
une image: https://en.wikipedia.org/wiki/Alsamixer ... amixer.png
Image


Tu dois avoir plusieurs jauge dont une s'appelle Master. Tu bascules sur les différentes jauges en utilisant les flèches de gauche et droite. La jauge sélectionnée voit son nom passer du vert au rouge.

Si tu n'as qu'une jauge peut-être que tu n'es pas sur la bonne vue, essaye les touches F3, F4 ou F5

Sinon la touche F6 te permet de changer le choix de la carte son (bien que sur un eePC), je pense qu'il doit en avoir qu'une seule carte son.

Très vieux Pingouin
Message(s) : 265
Inscription : 23 Juil 2015 13:56

Re: Soucis Debian sur EeePC

Message par frem » 12 Jan 2016 00:34

Bon, au moins on a le modèle de ton PC : un Asus Eee PC 1015CX.

Bon, sans m’avancer, on dirait un petit problème de processeur…
En complément, un petit Memtest serait effectivement des plus intéressant.

Tu m’avais dis que tu ne souhaitais pas conserver Windows car ce pc ramait vraiment. Avais-tu eu des plantages brutaux (écran bleu) sous Windows ces derniers temps ?
Sais-tu s’il a déjà eu des problèmes de surchauffe ?

Tiens-nous au courant de son passage chez ton pote.

Très vieux Pingouin
Message(s) : 265
Inscription : 23 Juil 2015 13:56

Re: Soucis Debian sur EeePC

Message par frem » 12 Jan 2016 00:37

agaric a écrit :Si tu n'as qu'une jauge peut-être que tu n'es pas sur la bonne vue, essaye les touches F3, F4 ou F5
Sinon la touche F6 te permet de changer le choix de la carte son (bien que sur un eePC), je pense qu'il doit en avoir qu'une seule carte son.

Là par contre, c’est peut-être une erreur de ma part : j’ai voulu être plus royaliste que le roi et j’ai fait une installation avec seulement les pilotes et firmwares libres.
Je pensais avoir vérifié que tout fonctionnait (réseau WiFi,…), mais j’ai oublié de vérifier le son…
Donc il manque peut-être le pilote pour la carte son !

Si tu récupère le PC et qu’il fonctionne encore, pourrait tu nous envoyer une capture d’écran d’alsamixer ou au moins les informations indiquées en haut à gauche ("Card" et "Chip"), pour connaître le modèle de ta carte son ?

Retour vers Entraide Linux