surventilation de mon cher ordinateur

Venez poser vos questions, répondre aux interrogations des autres ou simplement vous renseigner.
Oeuf
Message(s) : 3
Inscription : 15 Fév 2016 13:35

surventilation de mon cher ordinateur

Message par justine » 25 Août 2016 23:51

Bonsoir/jour à tous!
On dirait que mon ordinateur a envie de vous recontacter :)
Il est pris de surventilation... J'ai fait un premier pas douteux vers mon indépendance informatique...échec: http://forum.ubuntu-fr.org/viewtopic.php?id=257029 j'ai l'impression qu'il n'y a pas de processus qui me semble demander beaucoup plus d'énergie que les autres (enfin sauf niveau CPU%, gnome-shell 100%, fwupd*3:100%) (ça pourrait être ça?)
Voila, voila si jamais vous avez des conseils pour que je tente de régler ce problème j'en serais bien aise!
A bientôt!!

Grand Pingouin
Message(s) : 101
Inscription : 12 Oct 2015 11:25

Re: surventilation de mon cher ordinateur

Message par agaric » 26 Août 2016 00:56

Bonjour,

Si déjà un processus prend beaucoup de CPU tout le temps, c'est pas normal surtout pour un environnement de bureau comme Gnome-Shell.
Autre possiblité, la carte graphique qui a un pilote déficient pour la gestion de la température/ventilation.

Il possible de suivre la température des composants d'un ordinateurs: https://doc.ubuntu-fr.org/lm-sensors

Je n'ai pas un seul des programmes, prudence donc surtout que certains programmes semble marcher dans les veilles versions de Gnome et pas forcément avec Gnome-Shell.

Sinon fwupd est un programme de mise à jour: si il tourne à fond les ballons c'est qu'il a du travail à faire. Ton ordinateur est à jour, tu arrives à télécharger la liste des paquets.

Tu es sous Debian, Ubuntu ?

Oeuf
Message(s) : 3
Inscription : 15 Fév 2016 13:35

Re: surventilation de mon cher ordinateur

Message par justine » 26 Août 2016 01:35

Merci de ta réponse!

Je suis sous Ubuntu 16.04. Et il faut que je précise que c'est un problème récent. Il se peut que ça vienne de mes deux cartes graphiques (il m'avait semblé qu'une d'entre elle était devenue "dormante"...)-pardonne mon langage de débutante.

La j'ai essayé de télécharger cpulimit sans succès, et puis je n'ai pas aptitude, j'ai essayé de le télécharger, réponse:

Le programme « aptitude » n'est pas encore installé. Vous pouvez l'installer en tapant :
apt install aptitude
root@justine-HP-Notebook:/home/justine# apt install aptitude
Lecture des listes de paquets... Erreur !
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/fr.archive.ubuntu.com_ubuntu_dists_xenial_main_binary-amd64_Packages
E: Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.

En revanche sudo killall fwupd a plutôt bien fonctionné puisque le ventilateur ventile parfois moins fort.

Finalement il me semble que le problème est semblable à celui-ci:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1591868
Et très particulièrement à celui la:
http://askubuntu.com/questions/789385/s ... untu-16-04

Très vieux Pingouin
Message(s) : 265
Inscription : 23 Juil 2015 13:56

Re: surventilation de mon cher ordinateur

Message par frem » 29 Août 2016 12:00

Salut Justine,

justine a écrit :J'ai fait un premier pas douteux vers mon indépendance informatique...échec: http://forum.ubuntu-fr.org/viewtopic.php?id=257029

Donc ménage, c’est fait…

agaric a écrit :Tu es sous Debian, Ubuntu ?

Ubuntu GNOME 16.04 amd64, installé le 18 août en remplacement de Debian Jessie amd64 car nous ne trouvions pas de solutions pour la double carte graphique.

justine a écrit :gnome-shell 100%

Ça n’est effectivement pas normal !
Pour vérifier les ressources processeur et mémoire, ainsi que les processus, tu peux utiliser :
  • avec une interface graphique : le moniteur système de GNOME
  • en ligne de commande/cli et donc à lancer dans un terminal : top ou htop (mieux car en couleur :-)

Pour vérifier le comportement de GNOME Shell, lance le moniteur système ou htop et si gnome-shell est à 100%, tu le relances en tapant Alt-F2 (une boîte de dialogue "Enter a Command" doit s’afficher) puis r puis Entrée. Le bureau va alors se relancer et tu vas pouvoir vérifier s’il prend toujours 100% de ressources.

justine a écrit :fwupd*3:100%

Je pense que le cœur du problème est là ! fwupd permet de mettre à jour les programmes internes de petits matériels (sondes de calibration d’écran,…). C’est encore un programme un peu jeune, je suis très surpris qu’il soit déjà embarqué dans Ubuntu !
On à l’impression qu’il est planté et bloque le processus de mise à jour…

justine a écrit :En revanche sudo killall fwupd a plutôt bien fonctionné puisque le ventilateur ventile parfois moins fort.

Il est possible que le processus soit relancé de temps en temps par le gestionnaire de service du système.
Il serait alors utile de l’arrêter dans la session en cours puis de le désactiver complètement :
  • arrêter le service, pour éviter que le processus soit relancé dès qu’on l’arrête : sudo systemctl stop fwupd.service (demander au gestionnaire de service systemctl d’arrêter (stop) le service fwupd)
  • désactiver le service : sudo systemctl disable fwupd.service
  • tu peux alors arrêter ses processus plantés (killall …) et vérifier l’action : ps -e | grep fwupd (afficher la liste des processus (ps -e) et la filtrer (| grep) pour n’afficher que ce qui contient fwupd)

justine a écrit :root@justine-HP-Notebook:/home/justine# apt install aptitude
Lecture des listes de paquets... Erreur !

Après la désactivation de fwupd, tu peux faire un sudo apt udpate pour vérifier que rien ne bloque la partie mise à jour puis un sudo apt upgrade pour mettre à jour le système.

justine a écrit :https://bugs.launchpad.net/ubuntu/+sour ... ug/1591868

Il semblerait que le problème ai été corrigé par le développeur. La correction devrait arriver dans Ubuntu…

Pour info, un autre truc qui peut pas mal bouffer, c’est Firefox, vérifie aussi son utilisation processeur.

Retour vers Entraide Linux